Vai Indietro   PcTuner Forum > Sezione Hardware > Programmazione PIC
Arcade Registrazione Blogs Regolamento Feedback FAQ Lista Utenti Calendario Segna come Letti

Ultimi 5 blog pubblicati su PcTuner Blog
Data Titolo

Rispondi
 
Strumenti Discussione Modalità Visualizzazione
Vecchio 21-07-2007, 12.56.51   #1
Registered User
 

Iscritto da: 26-06-2007
Messaggi: 4
Feedback: (0)
ProPic 2 clone e 16F84A!!

Salve....sono nuovo....e come tutti i nuovi ho un problema riguardante il programmatore da ma costruito, cioè il propic2 clone (schema trovato su internet) e il PIC 16F84A.
Il problema consiste nel fatto che, avviando WinPic800, non riconosce il PIC e non mi permette di fare niente. Il corretto funzionamento del programmatore l'ho testato con un 16F876 sempre su WinPic e con quello tutto funziona. Ho ricontrollato se cambiando l'impostazione software del PIC da scrivere su WinPic anche i piedini di Vss, MCLR, Vdd, ecc.. cambiavano posizione sul programmatore e tutto sembra apposto. Anche i valori dei piedini sono ok, l'unica cosa che ho notato strana è che, essendo + piccolo come PIC il 16F84A del 876, sul tester i valori dei piedini quando il programmatore scrive non arrivano perfettamente a 13 V (esempio MCLR) oppure 5 V per gli altri. Aspetto vostre risposte e aiuti! Grazie in anticipo Ciao
kappa89 Non in Linea   Rispondi Citando
Vecchio 21-07-2007, 14.12.35   #2
Tuned Moderator
 
L'avatar di  naimah
 

Iscritto da: 21-08-2006
Locazione: Pistoia
Messaggi: 1,761
Feedback: (1)
Controlla bene le connessioni e prova a programmare un altro 16F84, il tuo sembra un problema prettamente hardware. Ah, controlla molto attentamente anche la VPP, sul mio è a 13.8V fissi ed è molto importante che rimanga stabile: eventualmente controlla l'alimentatore....
naimah Non in Linea   Rispondi Citando
Vecchio 21-07-2007, 15.26.58   #3
Registered User
 

Iscritto da: 26-06-2007
Messaggi: 4
Feedback: (0)
ho controllato la Vpp e la mia non è a 13.8 V ma a 13.55 V fissi...non varia di un centesimo...troppo bassa dici?
kappa89 Non in Linea   Rispondi Citando
Vecchio 22-07-2007, 12.05.08   #4
Tuned Moderator
 
L'avatar di  naimah
 

Iscritto da: 21-08-2006
Locazione: Pistoia
Messaggi: 1,761
Feedback: (1)
Quote:
Originariamente inviato da kappa89 Visualizza Messaggio
ho controllato la Vpp e la mia non è a 13.8 V ma a 13.55 V fissi...non varia di un centesimo...troppo bassa dici?
Avevo capito che stavi sotto i 13 ; comunque per curiosità ho provato a giocherellare con il mio programmatore e fino a 12.2 riesco a programmare. Sotto 12.2 mi da errore di verifica/scrittura
Cambia PIC e ricontrolla l'hardware
naimah Non in Linea   Rispondi Citando
Rispondi Per le vostre immagini su questo forum potete usare PcTunerUp!
Iscriviti gratuitamente alla nostra newsletter.


Utenti attualmente attivi che stanno leggendo questa discussione: 1 (0 utenti e 1 visitatori)
 
Strumenti Discussione
Modalità Visualizzazione

Regole di scrittura
non Puoi inserire messaggi
non Puoi rispondere ai messaggi
non Puoi inviare allegati
non Puoi modificare i tuoi messaggi

codice vB è Attivo
Smilies è Attivo
[IMG] il codice è Attivo
Il codice HTML è Disattivato
Trackbacks are Disattivato
Pingbacks are Disattivato
Refbacks are Disattivato
Vai al Forum


Tutti gli Orari sono GMT +2. Attualmente sono le 20.22.33.


Powered by vBulletin Versione 3.6.12
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.2.0
Copyright © 2010 - Master New Media S.r.l. a socio unico - P.I. 02947530784. Tutti i diritti di proprietà letteraria e artistica sono riservati- Privacy
www.pctuner.net è testata telematica registrata presso il Tribunale di Torino, n. 39 del 07.05.2008, Editore Master New Media S.r.l.